Foren: Offene Diskussion (Thread #4783)

旧バージョンTeslaのアンインストール (2004-03-14 10:05 by kirie #8657)

以前から,Teslaを使わせていただいています。
ねる氏の改変による"TeslaForPanther"をPBG4でしばらく使用していたのですが,Tesla2.0をインストールするために, /System/Library/StartupItems/Tesla/ を,Finder上でゴミ箱に捨てた後,  Tesla2.0をインストールしました。再起動後, Tesla動作をまだオンにしていない状態で,なぜか親指シフトが可能になっていました(";"が"BS"になっている)。また,Tesla動作をオンにし,Tesla環境設定でshiftキーを半濁音キーに設定した後も,Shift+Hで「ぱ」ではなく「H」が出力されます。
(Teslaを初めてインストールした別マシン(PBG3,OS10.3)では,Tesla2.0は正常に動作しています。)
再度ターミナルからTeslaを削除して再インストールしても,正常に動作しません。こういう場合にTesla2.0を正常動作に復帰させる方法があったら,教えていただきたいのですが。

RE: 旧バージョンTeslaのアンインストール (2004-03-15 22:03 by shibataseiji #8673)

最短の方法ではないでしょうが,思いつく解決法をあげてみます。

1. ルートユーザーとしてログインするか,sudoを使うかして,terminalで
kextstat
を実行してみてください。機能拡張の一覧に
jp.shibata.kext.tesla (2.0.0)とあればv2.0が動作しています。それ以外
のバージョンが起動している場合には,
kextunload jp.shibata.kext.tesla
として,機能拡張をアンロードしてください。

2. 念のため,Finderの検索機能などを使って,ローカルディスク上で"tesla"を検索し,古いファイルが残っていたら(できればterminalでrmコマンドを使って)削除する。

3. ファイル削除したらシステムを再起動し,再度kextstatコマンドを実行してシステムにteslaがロードされていないことを確認する。

4. teslaのインストールパッケージを実行して,teslaをインストールする。

おそらくこれで解決できるのではないかと思います。
Reply to #8657

RE: 旧バージョンTeslaのアンインストール (2004-03-16 23:23 by kirie #8681)

教えていただいた方法で、無事解決しました。
大変助かりました。ありがとうございました。
On/OFFやキーレイアウトが即座に変更できて、とても重宝しています。
Teslaには末長くお世話になると思いますが、今後ともよろしくおねがいします。
Reply to #8673

RE: 旧バージョンTeslaのアンインストール (2004-03-22 12:09 by shibataseiji #8804)

もしかすると,ドライバのキャッシュがのこっているのもしれません。
/System/Library/Extension
にある
Extensions.kextcache

Extensions.mkext
を削除(あるいは退避)して再起動すればうまく行くのではないでしょうか。
なお,万が一ということもあり得ますので,念のためにセーフブートの方法を調べてから,これらの手順をとられた方がよいかと思います。
Reply to #8681

RE: 旧バージョンTeslaのアンインストール (2004-03-18 02:31 by kirie #8722)

解決した…と思ったのですが、再起動すると再び同じ症状が発生してしまいました。
Tesla2.0をオンにしないまま、kextstatしてみると、
79 0 0x69d000 0x3000 0x2000 jp.shibata.kext.tesla (1.0.0) <18 10>
と、旧バージョンがロードされています。
そこで、rootから kextunload jp.shibata.kext.tesla してみると、
kextunload: /Users/kirie/jp.shibata.kext.tesla: no such bundle file exists
can't add kext (file access/permissions).
kirie:/Users/kirie root# kextunload: /Users/kirie/jp.shibata.kext.tesla: no such bundle file exists
su: kextunload:: command not found
kirie:/Users/kirie root# can't add kext (file access/permissions).
となっていました。何か別の対処法はあるでしょうか?
Reply to #8657

RE: 同様の症状になります (2004-03-22 11:44 by naktak #8803)

検索でTesla関係を削除して再インストールしましたが
kextstat
で1.0.0となります
システム環境設定で設定を変更しても,オンオフやBSキーの設定など
反映されていないようです
(親指シフト変換はできています)
Reply to #8657

RE: やってみましたが・・・ (2004-03-24 11:10 by naktak #8849)

Extensions.kextcache
Extensions.mkext
削除してみましたが,あいかわらず1.0です
インストーラがアップデート失敗しているのでしょうか
手動インストールみたいなことはできないでしょうか
Reply to #8657

RE: やってみましたが・・・ (2004-03-24 12:35 by shibataseiji #8853)

手動でインストールをするには,ソースからコンパイルする必要があります。

しかし,やはりどこかに古いファイルが残っているように思われます。
以前,「Finderで検索を…」と書きましたが,Finderの検索コマンドではSystemなどのディレクトリ内は検索できないようなので,Terminalで
sudo find / -name "Tesla.kext" -print
として検索し直してみてください(ディスクの容量によってはかなり時間がかかります)。
また,kextunload jp.shibata.kext.teslaでうまくいかない場合は,kextunloadのあとに検索でみつかった場所のフルパスを指定してみてください。
Reply to #8849

RE: やってみましたが・・・ (2004-03-24 15:34 by kirie #8855)

ターミナルから sudo find / -name "Tesla.kext" -print
してみると、/System/Library/Extensions/Tesla.kext が見つかったので、削除後再起動したら動作が正常に戻りました。(^^)
kextstat して確認しましたが、Tesla2.0が動いています。
Reply to #8853

RE: できました (2004-03-25 00:20 by naktak #8870)

手取り足取りおしえていただいたおかげで,やっと1.0を追い出すことができました
正しく2.0.0が動作していることを確認しました
ありがとうございました
Reply to #8657