• R/O
  • HTTP
  • SSH
  • HTTPS

linux-2.4.36: Commit

2.4.36-stable kernel tree


Commit MetaInfo

Revision05a3c5f2447cfac3fea73d21e6cf0e3fd8204da6 (tree)
Zeit2008-09-22 13:32:20
AutorWilly Tarreau <w@1wt....>
CommiterWilly Tarreau

Log Message

doc: fix examples and add suggestions about depmod

Grant Coady has reported these useful suggestions and workaround
for possible build errors related to building a new compiler.

Signed-off-by: Willy Tarreau <w@1wt.eu>

Ändern Zusammenfassung

Diff

--- a/Documentation/using-newer-gcc.txt
+++ b/Documentation/using-newer-gcc.txt
@@ -161,11 +161,21 @@ above, or /usr/local/bin if none was specified :
161161 The compiler just has to be passed to "make" via the "CC" variable for all
162162 commands :
163163
164- $ make CC=/opt/kgcc/bin/kernel-gcc -j 4 dep bzImage modules modules_install
164+ $ make CC=/opt/kgcc/bin/kernel-gcc -j 4 dep bzImage modules
165+ $ sudo make CC=/opt/kgcc/bin/kernel-gcc modules_install install
165166
166167 or more simply, when you have it in your path :
167168
168- $ make CC=kernel-gcc -j 4 dep bzImage modules modules_install
169+ $ make CC=kernel-gcc -j 4 dep bzImage modules
170+ $ sudo make CC=kernel-gcc -j 4 modules_install install
171+
172+Note: make modules_install needs a 2.4-compatible depmod. If your distro is
173+ 2.6-based and says it does not find depmod or depmod.old, it means that
174+ either modutils or module-init-tools have not been correctly installed.
175+ You can still force the path to depmod by passing it in the DEPMOD
176+ variable during make modules_install if you know where to find a good
177+ one.
178+
169179
170180 7) I want to use a really old compiler, but compiling it breaks!
171181 -----------------------------------------------------------------
Show on old repository browser