Downloadliste

Projektbeschreibung

Mac OS X の Mail.app を用いたメールの送信時に,Unicode文字のチェックを行い,必要に応じて文字の置換を行うとともに,日本国内で一般にメールのやり取りに用いられている ISO 2022-JP エンコーディングで送信を行うように設定するプラグインです。注:このプラグインには,受け取った文字化けしたメールを閲覧時に修正するための機能はありません。あくまでも,送信メールのテキストエンコーディングをISO 2022-JP に設定するためのプラグインです。

macOS 10.5 - 11.0.1 に対応

(macOS 10.9 - 10.15.7 に対応のバージョンは,2.9までとなります。また,Mac OS X 10.5 - 10.8.5 に対応のバージョンは,1.4.0までとなります。)

アンインストール方法

2.6.0までのバージョンは、/Users/(ユーザ名)/Library/Mail/Bundles/ にプラグインのファイルをインストールしています。 「/Users/(ユーザ名)/Library」は,Finderのメニューの「移動」をOptionキーを押しながら開いて,「ライブラリ」を選択するとアクセスが可能です。 2.7.0以降では,/Library/Mail/Bundles/ にプラグインのファイルを作成します。

アンインストールしたい場合は,LetterFix.mailbundle をゴミ箱に移動して,Mail.appを再起動してください。

なお,macOS Mojave以降 では,Mail.appの環境設定内にある,プラグインの管理でチェックボックスを外しMail.appを再起動する必要があります。

Mail.appの問題の解説

標準状態のMail.appでメールを送信する時,次の2つのパターンで受信側で文面が文字化けする場合があります。

Mail.app は,ISO 2022-JP エンコーディングで送られてきたメールに返信する時,標準の UTF-8 + Base64 ではなくISO-2022-JP エンコーディングでメールを送信しようとします。この時に,返信の文面に Unicode 文字が含まれていると,ISO-2022-JP-2 というテキストエンコーディングでメールを送信します。このエンコーディングには,ほとんどのメールソフトが対応していませんので,Unicodeに対応していたとしても,高い確率でメールの文字化けが発生します。これが1つ目の問題です。

もう1つは,Unicodeに対応しない古いメールソフトで受信される場合です。Mail.appは,ASCII文字以外が文面に入っている場合,UTF-8 + Base64 エンコーディングでメールを送信するため,一部の受信メールソフトでは正しく表示が行われない可能性があります。

本プラグインは上記の問題に対して、ISO-2022-JPに変換できないUnicode文字を置き換えることで、ISO-2022-JPでメールを送信可能にします。またダイアログでUnicode文字をそのまま送信する選択をした場合にも,強制的に UTF-8 + Base64 エンコーディングに設定して送信することで問題の発生を防止します。

制限事項

ファイルを添付したメールでは,件名等のヘッダーは UTF-8 + MIME エンコーディングで送信されます。また、High Sierra以降では,添付がない場合でも,ヘッダーがUTF-8+MIMEエンコーディングになります。

またメール本文の行毎の文字数が一定値を超えるとquoted-printable形式で 送信されることを防ぐことはできません。

謝辞

このプラグインを作成するにあたり,

を参考にさせていただきました。

Systemanforderungen

Die Systemvoraussetzungen sind nicht definiert

Veröffentlicht: 2020-10-18 18:15
letter-fix 3.0.0 alpha 2 (1 files Verstecken)

Versionsanmerkungen

アルファ版です。ご注意ください

  • macOS Big Sur 11.0 beta に試験的に対応させました。
  • OSの正式版のリリースまでには Mail の仕様変更も十分予想されますので,本プラグインの Big Sur 対応版を最終的にリリース可能であるかは現時点では未確定です。
  • またメジャーバージョンアップのため,思わぬ不具合が存在する可能性があります。ご理解の上でご使用ください。
  • インストール後,Mail の一般環境設定でプラグインの有効化や無効化などの管理を行う必要があります
  • 本アルファ版は,macOS 10.15 Catalina 以前にはインストールできません。(Big Sur の Mail ではプラグインの署名・公証が必須となる一方で,Catalina以前の Mail は署名したプラグインを読み込めないため,Big Sur 専用となっています。)
  • macOS Catalina 10.15 以前用には,2.9 をご使用ください。
  • 本アルファバージョンから,Apple Silicon(Arm)版のバイナリを含んでいますが、動作等の検証は一切行っておりません。

Änderungsprotokoll

  • macOS Big Sur 11.0 beta 10 (20A5395g で動作確認。
  • 一般環境設定でプラグインを有効化する際に、セキュリティの注意事項が表示されるようになったため、インストーラーに記述を追加。