Ticket #43463

Deprecation warning about old-style fcdb.option() parameter

Eröffnet am: 2021-12-22 17:30 Letztes Update: 2022-01-07 15:30

Auswertung:
Verantwortlicher:
Typ:
Status:
Geschlossen
Komponente:
Meilenstein:
Priorität:
5 - Mittel
Schweregrad:
5 - Mittel
Lösung:
Gefixt
Datei:
1

Details

Passing parameters like fcdb.param.DATABASE to fcdb.option() has been deprecated since freeciv-2.5. Let's add a deprecation warning about it. The implementation (to detect such calls) I have in mind might have some theoretical issues rendering it to a d3f matter -> can't be applied to branches older than S3_1.

Ticket-Verlauf (3/4 Historien)

2021-12-22 17:30 Aktualisiert von: cazfi
  • New Ticket "Deprecation warning about old-style fcdb.option() parameter" created
2021-12-30 12:01 Aktualisiert von: cazfi
  • Lösung Update from Keine to Accepted
2022-01-07 15:30 Aktualisiert von: cazfi
  • Status Update from Offen to Geschlossen
  • Verantwortlicher Update from (Keine) to cazfi
  • Lösung Update from Accepted to Gefixt

Bearbeiten

You are not logged in. I you are not logged in, your comment will be treated as an anonymous post. » Anmelden