Ticket #42959

clearer action names

Eröffnet am: 2021-09-30 23:32 Letztes Update: 2022-03-31 22:48

Auswertung:
Verantwortlicher:
Status:
Geschlossen
Komponente:
Meilenstein:
Priorität:
5 - Mittel
Schweregrad:
5 - Mittel
Lösung:
Gefixt
Datei:
2

Details

Action names in the UI can be a little confusing.

"Recycle Unit" - sounds like it might have to do with the environment, pollution etc. - is it connected to Recycling Center?
In addition, to recycle a human being (e.g. Warrior, Musketeer) might be a little cruel as a metaphor.

"You're Fired" - maybe intended as a joke, but it is politically charged unlike other text in the game, and doesn't fit grammatically.

Cruel and arrogant language may be especially appropriate where it concerns the enemy, but in this case it is about your own troops, so some more euphemistic term would make it sound more realistic.

Currently the client also has a Disband menu item, so it is three different terms for the same general idea.
My suggestion: for the action names, how about plain "Disband recovering production" and "Disband without recovering production"? It is dull and verbose, but so is the concept. Not introducing additional metaphors makes it easier to sensibly translate to other languages.

I think it would also be a good idea to group similar actions together in the UI, with similar wording and close-together locations in the menus. Currently in the "Go to and..." menu, "Recycle Unit" tends to be near the top, "You're Fired" near the bottom, and "Disband" is an entirely different menu.

Ticket-Verlauf (3/13 Historien)

2021-09-30 23:32 Aktualisiert von: log65536
  • New Ticket "clearer action names" created
2021-10-01 09:04 Aktualisiert von: cazfi
Kommentar

We may want to split this to two tickets. This ticket would become just changes to supplied rulesets (ui_names) that would be applicable even to S3_0. A new ticket would be about changing names of the underlying actions, only possible in S3_1 and later as S3_0 ruleset format is frozen.

2021-11-10 11:13 Aktualisiert von: cazfi
Kommentar

Reply To log65536

I think it would also be a good idea to group similar actions together in the UI, with similar wording and close-together locations in the menus. Currently in the "Go to and..." menu, "Recycle Unit" tends to be near the top, "You're Fired" near the bottom, and "Disband" is an entirely different menu.

I think this is what https://www.hostedredmine.com/issues/920376 tries to achieve.
2022-01-02 11:22 Aktualisiert von: cazfi
2022-01-11 15:17 Aktualisiert von: cazfi
Kommentar

Reply To cazfi

We may want to split this to two tickets. This ticket would become just changes to supplied rulesets (ui_names) that would be applicable even to S3_0. A new ticket would be about changing names of the underlying actions, only possible in S3_1 and later as S3_0 ruleset format is frozen.

Arranged the tickets the opposite way. This has already been targeted to S3_1-d3f, so keep this for changing the underlying action names (full implementation). The new ticket, that should be done first, to make the ui_name changes -> #43595

2022-01-26 13:12 Aktualisiert von: cazfi
  • Komponente Update from Rulesets to General
2022-03-14 12:15 Aktualisiert von: cazfi
Kommentar

Working on this. Compatibility code for loading freeciv-3.0 rulesets to S3_1 is already ugly (e.g. global variable in common/ telling if action_by_rule_name() should support compatibility names), and I've not hit with the fact that number of places load action vectors with secfile_lookup_enum_vec(). We likely need to provide facility for that function to support alternative names to the ones that the current enum has -> starting to consider if changes of that magnitude (compared to the benefit) should be postponed to 3.2.

2022-03-14 12:55 Aktualisiert von: cazfi
Kommentar

Reply To cazfi

We likely need to provide facility for that function to support alternative names to the ones that the current enum has

Specenum seems like a place to add it to -> #44100

2022-03-14 13:51 Aktualisiert von: cazfi
Kommentar

Reply To cazfi

(e.g. global variable in common/ telling if action_by_rule_name() should support compatibility names)

Split to -> #44101

2022-03-19 16:26 Aktualisiert von: cazfi
Kommentar

Patches attached. S3_1 one depends on #44101 and #44100 for freeciv-3.0 ruleset compatibility mode implementation.

As the master (3.2) will expect any 3.1 -compatible ruleset to already have the new names in use (it's not something to convert in 3.1 -> 3.2 update), S3_1 patch needs to be pushed in first. Then we get the git commit hash from that commit, and create second master patch to set that hash to tests/rs_test_res/upgrade_ruleset_sync.bash. Then those two master commits are pushed in together. As the second patch can be created only when we are pushing this in, it won't have 36h review period, but luckily it's a trivial change of the hardcoded hash value.

2022-03-31 22:48 Aktualisiert von: cazfi
  • Status Update from Offen to Geschlossen
  • Verantwortlicher Update from (Keine) to cazfi
  • Lösung Update from Keine to Gefixt

Bearbeiten

You are not logged in. I you are not logged in, your comment will be treated as an anonymous post. » Anmelden