• R/O
  • HTTP
  • SSH
  • HTTPS

master: Commit

embrj master repositories


Commit MetaInfo

Revision0c70a094b6b2756226f2a948bb159a913301f040 (tree)
Zeit2019-05-19 03:55:53
Autorjianghgr <jianghgr@user...>
Commiterjianghgr

Log Message

xctcc/embrr

Ändern Zusammenfassung

Diff

--- a/README.md
+++ b/README.md
@@ -36,52 +36,3 @@ Notes
3636 If you're having issues changing pages or sending DMs, try modify your `php.ini` as follows:
3737
3838 precision = 24 ;Use a value lager than 19 to replace the default 14
39-
40-----
41-
42-embrr, 一个修改版的 embr
43-========
44-
45-这是一个从 [embr](https://code.google.com/p/embr/) 修改而来的 twitter 网页端,主要基于 `r91` 版本并合并了后续修订版的必要更新,升级到了 Twitter REST API `v1.1` 并有一些功能上的改进。
46-
47-如果不想使用 `git-clone` 获取代码,可以点[这里](https://github.com/AstroProfundis/embrr/zipball/master)下载当前版本的 zip 压缩包。
48-
49-安装方法
50---------
51-安装 embrr 的方法和 embr 原版基本相同,只需要下载代码包,重命名 `/lib` 中的 `config.sample.php` 文件为 `config.php`, 编辑此配置文件填入适当的 app 信息,再将代码上传至网站空间即可。
52-
53-有几点值得注意的地方是:
54-
55- * embrr 依赖于 `php-curl` 和 `php-bcmath` 组件
56- * 虽然不是必需依赖,但建议安装 `php-mcrypt` 组件
57- * embrr 兼容 PHP 5.2 至 5.5 的版本,我们没有测试过 5.1 及之前版本
58-
59-在二级目录中安装
60---------
61-如果需要将 embrr 安装在二级目录中,例如安装在 `/embrr` 中,则需要修改 `.htaccess` 文件,使用 `/embrr/user.php` 与 `/embrr/status.php` 替换 `/user.php` 和 `/status.php`.
62-
63-nginx
64---------
65-对于 nginx 用户,需要在配置文件中加入以下代码:
66-
67- location / {
68- if (!-f $request_filename) {
69- rewrite ^/(\d+)$ /status.php?id=$1 last;
70- rewrite ^/(\w+)$ /user.php?id=$1 last;
71- break;
72- }
73- }
74-同样,如果在二级目录中安装则需适当调整。
75-
76-附注
77---------
78-如果翻页或者发送 DM 时遇到问题,尝试在 `php.ini` 中做如下修改:
79-
80- precision = 24 ;使用大于 19 的值替换默认值 14
81-
82-----
83-As I'm not an expert of PHP nor twitter API, do expect bugs everywhere.
84-
85-All helps are welcomed!
86-
87-请做好 bug 满天飞的心理准备以及欢迎拍砖和协助修改。
Show on old repository browser